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1 

NOTE:  This quick-start guide is intended to provide quick answers to common questions 

associated with the WinSeis 1.8 software. This guide is not intended to be a replacement for the 

educational background for reflection seismic-data analysis, which is necessary to  allow users to 

understand the concepts used in WinSeis, nor is it intended to replace the tutorial, sample data, 

manual, and other documents provided. To address questions in more detail, please refer to the 

tutorial and manual provided with the software. SEG Wiki  and other information on the web can 

be helpful, as well. This document provides links to some web pages. 

 

INSTALLATION INSTRUCTIONS 
Please insert the installation disc and follow the instructions provided in the installation window.  

The default location for the installed WinSeis software will be to the HDD that is associated with 

your operating system.  It is advised that this default location not be changed (e.g., WSeis18). 

 

Contents 
Once WinSeis 1.8 is installed, the default application folder (“WSeis18”) will contain a sub-folder 

called “Documents”. Within this folder there is another sub-folder named “How To”. This folder 

contains examples and an explanation on how to remove unwanted traces that are located in a 

given shot record. The next sub-folder located in “Documents” is called “Manual.”  This folder 

contains the Winseis Manual. This manual is divided into multiple PDF files, with each PDF 

containing one section of the manual (e.g., 4section1.pdf, 5section2.pdf, etc.).  These files may be 

printed and bound to generate a physical copy of the WinSeis Manual for your personal use.  This 

manual contains all the information needed to build the required “.dek” files for each process.  In 

the “Documents” folder there is also a PDF file entitled “EavesTutorial.pdf”,  which is the original 

step-by-step walkthrough developed for the WinSeis software. This tutorial refers to the data 

located in the “C:\WSeis18\SampleData” folder path. Using these sample data along with the 

tutorial can provide a basic understanding of a general processing flow as well as descriptions of 

what each process achieves. 

 

The “Utils” folder within the “WSeis18” folder contains executables that allow the conversion of 

data from various field acquisition file sources to the proprietary KGS format required by WinSeis, 

as well as to-and-from SEGY format.  The common data acquisition file type is SEG2.  The SEG2 

to KGS file conversion executable is located in the Main “WSeis18” folder. 

 

Executables that build “.dek” files required by the WinSeis 1.8 software are located in the 

“WSeis18” folder.  Additionally, software used to view the data is located in the same folder. 
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HOW TO 

Process Data 
The actual processing of the seismic data is performed by the “WSeis.exe” module (aka processing 

engine), which reads a “.dek” file (a simple text file) with information about the input data file, 

one or more processes to apply (defined by “commands” [*short word] with parameters), and  

output file(s). An output journal text file, “.lst”, is generated and updated with each process 

outcome providing processing information. 

 

Most of the remaining “.exe” modules in the main application folder (e.g., “C:\WSeis18”) are 

designed to help build such text “.dek” files. They may not be necessary, if users have mastered 

the use of the “commands” described in the manual.  If the user is proficient with the “commands”, 

it may be even more efficient to simply type the commands with the appropriate parameters in a 

“.dek” file and run it by launching the “WSeis.exe” module and selecting the corresponding “.dek” 

file. 

 

An easy way to run processing is to find the “.dek” file using File Explorer (available with 

Windows 10, aka “Windows Explorer” in previous Windows versions) and just double click on it.  

 

Best Place to Process Data 
First, save the acquired data to a folder on the “C:\” drive. 

 

For the generation of simple “.dek” files, it is easiest to first write the information into a “.txt” file 

using a simple .txt file editor, such as “Notepad” (which comes with the Windows operating 

system).  Once satisfied, go to “File > SaveAs” and take the “.txt” extension off and replace it with 

“.dek.” This will save the text file as a “.dek” file which “WSeis.exe” can read. 

 

NOTE:  Once a “.dek” file is made, it must be manually saved.  Closing the windows prior to 

saving will delete the work.  

 

“Cmdedit.exe”, which can be found within the “WSeis18” folder is a tool specifically designed  to 

create .dek files with friendly command-insertion options and tips.  

 

Converting Data 

SEG2 format seismic data 

In order to process seismic data using the WinSeis 1.8 software, the data acquired in the field must 

be converted from the field acquisition datatype (typically SEG2 format) to the proprietary KGS 

processing data type.  To convert the data from SEG2 to KGS format please use the following 

steps: 

 

Using File Explorer go to the WinSeis’ installation folder (e.g., “C:\WSeis18”  and double click 

on the “SEG22KGS.exe” file. Then select from the menu: 

  File > Select Inputs > “Select Range > OK > 

  File > Output > “Name Output File > OK > Convert 
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https://seg.org/Portals/0/SEG/News%20and%20Resources/Technical%20Standards/seg_2.pdf
https://en.wikipedia.org/wiki/File_Explorer
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This will now convert the SEG2 files to the KGS format.  This will allow the user to utilize the 

software. 

 

Check Figure 1.2 on page 1-4 from the WinSeis Manual (“4section1.pdf”).  

WinSeis Manual files can be found in the “C:\WSeis18\Documents\Manual” folder 

 

KGS and SEGY formats 

Using File Explorer go to the  “WSeis18\Utils” folder 

Use SEGY2FPT.EXE to     convert SEGY format data to KGS format. 

Use FP2segyf.exe (or FPT2SEGY.EXE) to   convert KGS format data to SEGY format. 

 

Merging Multiple Records Together 
If multiple files need to be merged/combined into one file, please follow these instructions: 

 

  Open MS-DOS Command Window > Change directory (cd) >  

  File Path > “COPY File.dat /b + File2.dat /b + … + FileN.dat = AllFiles.dat” > 

  ENTER > Repeat as necessary … 

 

The default MS-DOS-type Command Window is a black box with white type.  It can be located 

by searching “Command Prompt” in the Start Windows Search Bar. 

 

View Data 
WinSeis 1.8 comes with a seismic-data visualization program.  This will allow users to view either 

shot records or a final stacked section.  To see the data, follow these steps: 

Using File Explorer go to the  “WSeis18” folder and launch “Winview.exe” program. Then select 

from the menu: 

 

  File > Open > “Select File > OK” 

 

The viewing parameters can be changed in the “Options > Change Graphics” window. 

 

Check Figures 4.1 – 4.6  on pages 4.1 and 4.2 from WinSeis Manual (“7section4.pdf”). 

 

Application of Geometry 
Geometry is applied by using the *SORT command in a .dek file.  Geometry refers to the survey 

acquisition parameters (i.e., the locations of the sources and receivers). Geometry is applied after 

such information is written to the headers in the data (i.e., trace headers).  Without geometry 

information some processes, such as FK filtering, Muting, and Stacking cannot be accomplished.  

Small errors in geometry application can compound in further processing, contributing to 

substantial error in the finished product. 

 

Winsort.exe is a graphics tool within the “WSeis18” folder that can help with the making of 

sort.dek files (typically a laborsome and demanding process). 
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Based on the geometry information, data can be “sorted” (i.e., reordered, reorganized) from the 

acquired common shot records trace order into different “gathers”, such as common-mid-point 

(CMP) gathers. 

 

Sorting the data to CMP gathers is the only way to achieve normal-move-out (NMO) analysis 

using the constant-velocity stack (CVS) panel executable provided in WinSeis.  To generate a 

sorting “.dek” file using a program provided with WinSeis please follow the instructions below: 

 

Launch the “Winsort.exe”  program the  “WSeis18” folder. program. Then select from the menu: 

 

  File > Open “Select File” > Adjust Parameters > Make *SORT 

 

NOTE:  The data can be initially sorted using header words “92 8”, i.e., record and trace numbers.  

After vertical stacking, the most friendly sorting can be “87 86.”  After the data has been initially 

sorted through geometry, it is easiest to reorder it (i.e., reorganized, resorted) using the *RSRT 

command (rather than the *SORT again) into different gathers, such as CMP.  Please jump to the 

Resort section below for instructions. 

 

Check Figures 1.21 – 1.27  on pages 1.11 and 1.12 from WinSeis Manual (“4section1.pdf”). 

 

Frequency Filtering 
Frequency filtering “.dek” file preparations can be done using a program provided with WinSeis.  

Please follow the instructions provided below to generate the “.dek” files.  

 

Launch the “Winfilt.exe” program the  “WSeis18” folder. Then select from the menu: 

 File > Open File > Use the options to select the type of frequency filtering > 

 Enter the desired parameters into the software > 

 Make *FILT 

 

To generate the filtering “.dek” from scratch, please refer to the manual provided with the software 

in the Documents folder.  

 

Frequency-Wavenumber (FK) Filtering 

The FK filter is a subclass of the Winfilt.exe program.  To do FK filtering please follow these 

instructions.  

 

Launch the “Winfilt.exe” program the  “WSeis18” folder. Then select from the menu: 

 Options > FK filtering > File > Open > FileName > Pick FK values > 

 Make Command > Jump to next record > Continue… 

 

Check Figures 1.76 – 1.86  on pages 1.23 - 1.25 from WinSeis Manual (“4section1.pdf”). 

 

Killing Traces 
Killing noisy traces “.dek” file can be made using the “Winedit.exe”  program.  Please follow these 

instructions to kill traces.  
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Launch the “Winedit.exe” program in the “WSeis18” folder. Then select from the menu: 

File > Open > Filename > OK > Options > Edit Options > EDKL-Surgical Mute >  

Select Traces 

 

Muting 

Surgical Muting 

Surgical muting parameters for a “.dek” file can be selected using the “Winedit.exe” program.  

Please follow these instructions to achieve surgical muting. 

Launch the “Winedit.exe” program in the “WSeis18” folder. Then select from the menu: 

File > Open > Filename > OK > Options > Edit Options > EDMT-Surgical Mute >  

Select Mutes 

 

First Arrival Muting 

First arrival muting parameters for a “.dek” file can be selected using the “Winedit.exe” program.  

Please follow these instructions to achieve first arrival muting. 

Launch the “Winedit.exe” program in the “WSeis18” folder. Then select from the menu: 

File > Open > Filename > OK > Options > Edit Options > EDFM-Surgical Mute > 

Select Mutes 

 

Check Figures 1.28 – 1.39  on pages 1.33 and 1.14 from WinSeis Manual (“4section1.pdf”). 

 

Resort Data to CMP 
Resorting (reorganizing) the data traces to CMP gathers is the only way to achieve NMO analysis 

using the velocity panel executable provided in WinSeis.  Use the following text, as a “.dek” file 

example: 

 
 >>Start 

 *INPF C:\EXAMPLE.dat 

 *RSRT 12 19 

 *OUTF C:\EXAMPLE_RSRT.dat 

>>END 

 

Please refer to the manual to write the “.dek” file from scratch and to sort the data into other sorting 

formats. 

 

Velocity Analysis 
CVS panels are typically used for NMO velocity analysis.  The “Winvscn.exe” program generates 

constant-velocity stack panels to determine the proper NMO velocity and to generate a “.dek” file 

horizontally (i.e., CMP) dependent NMO velocity functions to be executed by “WSeis.exe”. 

 

Generate Panels 

Launch the “Winvscn.exe” program in the “WSeis18” folder. Then select from the menu: 

File > Open > “Select CMP Sorted Data” > OK (.DAT) >  

Select CMP and Velocity Range > 
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 File > SaveAs > “File Name” > Change name extension to “.NMO” (Drop Down) > 

 OK > Click “Generate Panels” 

 

View and Pick Panels 

Launch the “Winvscn.exe” program in the “WSeis18” folder. Then select from the menu: 

File > Change name extension to “.NMO” (Drop Down) > Select “.NMO” File > OK 

 

OR 

 

Velocity Estimation on CMP 
Another velocity estimation program is provided with the WinSeis 1.8 software package that 

estimates velocities on the uncorrected CMP gathers.  The program is called “Winvelp.exe”.  

 

Launch the “Winvelp.exe” program in the  “WSeis18” folder. Then select from the menu: 

 File > Open > “Select CMP Sorted Data” > OK > Check Parameters > OK 

 

CMP Stacking 
To stack the CMP data, please refer to the manual that was provided with the data.  In order to 

stack the data, it must be reordered (sorted) using header words “12 19” (CMP) sorting. 

 

TIPS 
Good Practices: 

1. Place the data to be processed in a separate folder on the C:\ drive.  This will minimize issues 

while processing. 

2. Files cannot exceed 2.1 GB (gigabytes) in size.  Keep all file sizes less than 1.5 GB to minimize 

issues while processing. 

3. Use short and meaningful file names while processing data to avoid confusion later on.  

4. After making “.dek” files using programs provided with the WinSeis software, it is a good 

practice to re-save the file as a “.txt” file as a backup in case something happens to the original 

file.  

5. If the user decides to make a “.dek” file from scratch, it is easiest to generate the information 

as a text file first.  Then re-save the text file as a “.dek” file by removing the “.txt” extension 

and adding “.dek” in its place. 

 

FAQ 
This section provides some of the most frequently asked questions and the most likely answer to 

why the error or question is being raised.  If the solutions provided below do not lead you to resolve 

the issue, please refer to the “.lst” file to solve the issue.  If the issue persists, please contact the 

KGS to address the issue. 

 

Why will my software not open? 

Please be sure your Sentinel USB Dongle is plugged into the computer and the light is red on the 

dongle (indicating the software is installed automatically by the computer). 
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How do I view the seismic data? 

Using File Explorer go to the “WSeis18” folder and launch the “Winview.exe” program  

WinView window will open. Go to “File > Open > Double Click on the .DAT file, which is in 

KGS format. 

 

How is WinSeis 1.8 different from the executables in the “WSeis18” folder? 

The majority of the executables in the folder allow for “.dek” files to be made that can be opened 

and executed by the “WSeis.exe” executable.  The only data processing is completed by opening 

and running “.dek” files in “WSeis.exe”. 

 

An error occurred in the processing, what happened? 

To troubleshoot what happened, open the “.lst” file that was generated from the processing in 

“WSeis.exe”.  It will be the same file name that was saved in the “.dek” file.  There will be a line 

that stars “Abnormal termination” followed by an error message.  This is a meaningful message 

that will illuminate what went wrong and point the user in the right direction to rectify the issue. 

 

What does the error “Ran out of disc space” mean? 

This error is associated with either an input or output file path name that is too long.  Please try a 

different, shorter file name. 

 

WinSeis continues to process and never stops.  The final file size is too large and the list file 

does not provide any meaningful solution.  What happened? 

“>>END” is missing at the end of the “.dek” file.  

 

What does “overflow” mean as an error? 

The file or operation is too large to be completed.  Please reduce the size of the file to below 1.5 

GB and try again.  Or, there is a user defined error.  Please check the “.dek” file to ensure the 

correct process is being done. 

 

Error “Divide by zero” in NMOT command. What does this mean? 

The stacking velocities cannot provide a realistic solution based on the surrounding velocities.  

Please refer to the “.lst” file to identify the problem picks.  Then correct and run again. 
 

OR 
 

Interval velocities were provided instead of the required stacking velocities. 

 

 

Check the KGS WinSeis FAQ web page for more. 
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https://en.wikipedia.org/wiki/File_Explorer
http://www.kgs.ku.edu/software/winseis/faq.html



