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Introduction
WEIEAT is a set of user-ffiendly programs developed at the KGS for the retrieval, analysis,
manipulation and display of infomation on natural resources. especially groundwater.  It
runs under the rmcrosoft Windows 3.1 operating system and is intended to be easy to use.
The principle goals in development of WERAT have been:  ease of use;  hardware
independence:  applicability to resource management problems;  end-user extendibhity;
and the abhity to exchange infomation with other analysis packages.

This document is intended for the beginning WHEAT user interested in displaying,
querying, and printing maps;  it provides some guidance on designing a database.

This open-ffle report is a "nving dceument", in that revisions will be made to it to reflect
new programs added, new chapters, or changes to old programs.  New programs and
changes to old ones will update and enhance older versions, so rarely will something that
worked in one version not work later.  It is organized into separate chapters describing
major programs.  This version includes E-MAP, the electronic mapper; the CoNToUR
program, and the database design guide.

The programs, included on the diskettes, are distributed without charge or warranty or
technical support  WlmT is not intended as a complete stand-alone package, and
certain capabflities are better provided througiv commerdally-available packages:
to fully use WREAT, each site should also have a relational database management system,
preferably NIcrosoft Access, a spreadsheet, and a presentation graphics package.

Organization of this report

Pat            Title
A                    User' s Guide to WREAT             (this cover document)
8                    How to use WIIEAI Electronic Mapper (E-MAP)
C                    How to Design and Build a WHEAI Database
D                    How to contour in WHEAT
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based on data processed using this software or dedsious based thereon.  Neither
agency provides free technical support.

Vlat is WlmAT
WmAI is a set of user-friendly programs developed at the Kansas Geological Survey

for the retieval, analysis, manipulation and display of infomation on natural resources,
especially groundwater.  It runs under the Microsoft (MS) Windows 3.1 operating system
and is intended to be easy to use.

WmAT is modular and menurdriven so users can lean by example as much or as rme
of the system as necessary for their needs.  WREAT does not require the detailed
understanding of the data model or extensive command vocatulary that many commercial
GIS or CJros require.

WlmT stores data in MSAccess databases:  using ExpoRTDB you can also export to
ASCH text files.  The end-user can extend and enhance WmT by writing programs to
manipulate data or to provide additional transfer capabilities with spreadsheets, mainframe
programs, and GIS systems.  (See the database design guide and WHrcoDE.MDB.)

Using E-MAP, the user can display tile (section), point, line, polygon, text label, and
grid data; select the viewing region by zooming and panning;  retieve infomation on a
geographic feat`ire by double{ficking on it with the mouse; and print maps direetly from
E-Map or copy to graphics programs for further manipulation using the Windows
Clipboard.  Maps can also be exported to Windows Metafiles.

CoNrouR allows the user to contour and interpolate point data.
Two programs are included to provide limited database manipulation capabhities:

GRDEDT01 ERE  is a spreadsheet-like table editor
RECEDITI EXE  allows editing of a single record in a database
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WmAT includes a number of specialized inport-export programs that are used
infrequently.  These include:

BLOBMEMO EXE  converts W'heat internal XY-BLOBS into ASCII chains of
coordinates and vice versa.  Lets you import virtuany any line data you as a
human can read.

FXDWDTHI EXE is used to import fixed-width files into Access.
For use with ARC/INFO imports and exports, there are:

ARCS_IN2 EXE inports ARC/INFO ungenerate fomat files into polygons or
lilrs

BELDPOLY EXE converts arc-node topology into chain topology used in
Wheat.  Unnecessary for use after ARC/INFO 6

EXPORTDB EXE  creates an ARC/INFO ABEL to define a table and a comma
separated value file containing the data to export from an Access-fomat
database.  Used to move tabular data into ARC/INFO.

System requirements
h addition to the computer (below), each site should have database management

software (that can use the ODBC interchange standard) for manipulating data in non-
graphical manner. such as Microsoft Access, and a Windows-based spreadsheet such as
E=£gl.  A presentation graphics package such as CorelDraw is also useful for `tirettying
up" maps.  (Software suggestions are the author's favorites, and do not constitute any
official endorsement. )

Program and attendant libraries take about 4MB of distf space.  WtlEAT will run on a
Windows for Workgroups network or under Windows - no claims can be made for other
netwolks or operating systems.

ndininun Computer
WIRAT will run on a computer that can run Microsoft Windows 3.1 programs.  For

PCs, at least a 386 with 2 MB RAM.  You will also need 4MB available disk apace for
programs; and a network connection to or disk space for the database.

Ihaired Computer
WmT, and especially E-MAP, will run ]aag]] on a 486DX with 8 MB RAM, a fast hard

drive, and a good (256 colors or more) video card with Windows 3.1.  Other
configurations are possible.  If you are buying a computer, I recommend (12/6/94) at least
a 486DX2/66, a 500 MByte hard dislL a 16 mi]lion¢olor video card, and a 15" monitor.
Because of the large size of the databases you will end up generathg, you will want to
back them up frequently, so you should probably also get a QIC-80 tape drive.
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Extending WIREAT
Under certain circumstances, Kansas Geological -Survey can contract to provide

enhancements to WmAT.  Contact Greg Pouch at KGS.
If you wish to extend WIIEAT yourself, there are several options.  If you need to

modify data and write your own data processing programs you can use MS Access or
Visual Basic.  If you want to modify the programs, you need Microsoft Visual Basic
Professional 3.0 or higher.  Many of the spatial query routines are in FORTRAN, so a
FORTRAN 16-bit compiler that can produce Windows Dynanric Link Libraries would be
needed.  The cursors nve in hdicrosoft Visual C++ resource-only Dynanic Link Library
cared W'ITI`CURS2.DLL.

Acknowledgments
These programs were developed at the Kansas Geological Survey. Lawrence, Kansas
during 1994 on the WmAT (Windows-based Hydrogcologic Exploration and Analysis
Toolkit) projeet, in cooperation with the Equus Beds Groundwater Management District
(GMD ne), Halstead, Kansas.

Kansas Geological survey open File Report 94-51 Part A              User's Guide to WREAT



1/7 E-MAP, How To 12/6/94

How to use WlmAT Electronic Mapper a]-MAP)
This dcoument explains the use of the electronic map G-MAP) tool included in the
Windows-based Hydrogeologic Exploration and Analysis Toolhit (WmAT).  It is intended
as a how-to introduction to E-MAP for general audiences. and assumes you already have a
database.  If you do not, USE TIHS MANUAL Wrlll TEE SArmLE DATABASE,
then, using the directions in How fo Desz.gn and B«z.Zd a WIEZEArD¢1zzbare to create a
database.
Using E-MAP, a non-specialist can open, design, save and print maps, as well as perfom
spatial queries on points by double-clicking.  Using LookupTable Editor anows the more
advanced user to design a legend and apply it to a table or query.  This document does not
explain the use of LookupTable Editor, or other importrexport tools

Greg Pouch
Kansas Geological Survey

Tuesday, December 06, 1994
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How WREAT stores data
WHEAT E-MAP uses data stored in a relational database.  Specificany, E-MAp uses

queries and tables stored in a Microsoft Access fomat database to provide both the
attributes and coordinates of various geographic features.

A relational database stores all infomation on a topic, such as water users or
schools, in tables.  Tables are organized sets of information containing records, one for
each individual thing in the database.  A record is composed of fields, which describe the
thing.  Thus, a table concerning schools might have records for each school in a county,
and the records might include the name (as text), date founded (as date), operating budget
(as a floating point number), date closed (as date), number of buses owned (as integer
number), principal's name (as text), and number of pupils (as integer number).  Notice that
some of the fields risted, such as date closed and number of buses, will not occur for each
individual school.  h these cases, a relational database stores a null, indicating that no
infomation is avanable.

While a relational database Sforcr infomation in tables, it can rcfrz.eve infomation
as virtual tables called queries,  A query is the answer to a question asked about the
datatable, such as:  "show all schools with an operating budget above $500,OcO''.  A query
can ret`im data from several related tables by joining them.  For example, suppose we had
another table containing infomation about students.  It might contain student's name, age,
address, and name of school attended.  We could then find out who a student's principal is
by designing a query which relates the school name field in the student table to the nane
field in the school table.  Queries ae generally used for combining infomation from
several tables, selecting subsets of records, or selecting subsets of fields.  By allowing data
to be stored in a single location (such as the principal's nane in the school field) and
related at a later time, relational databases can reduce storage requirements, and allow the
updating of data to be considerably easier than if each record contained all data that might
ever be needed.

E-MAP uses a relational database to store infomation about geographic features,
both their descriptive (or tabular) atributes and their locational atdibutes.  The lceation(s)
of feature are described as X (east-west) and Y (north-south).  WREAT does not use any
particular coordinate system, except that X and Y will be plotted as equal distances on the
screen and on printing, and X increases to the right and Y increases to the top.

For points (for plotting symbols or text), WlmT stores the X and Y locations in
separate numerical fields in the table.  These might be named something like Northing and
Basting or X and Y, although, since the fields containing ccordinates are chosen by the
user while nmning E-MAP, they can be named anything.  For features with multiple
locations, like the set of line segments defining a river or the boundaries of a county,
WmIAT stores the data in a special type of field called a Binary I.arge Object 03LOB or
XYBLOB).  This is simply a binary representation of a set of X and Y locations, stored as
a chain of points.

The attributes and locational infomation can all be stored in one table for each set
of items, or they can be stored in separate tables and related in a query.  Additionally,
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plotting instructions (like color, line width, and symbol) can be stored in a table or defined
as constants.

Displaying a Map with WlmAT EIMAP

Overview and Definitions
h WEnIAT E-MAP, a map consists of a set of overlain themes.  Each theme is

about a particular topic (such as political units or drainage basin or water appropriations)
and of a particular geomeric type (points, lines, ties, polygons, text labels, rastergrids;
defined below.)  Thus, a map of counties with a star at the county seat and a label for the
county would consist of three themes:  the lcoation of the county seats (points);  the
names of the counties (text labels);  and the outlines (polygon or line) of the counties.

In addition to points, lines, and polygons, WlmT E-MAp includes three other
useful geometric types.  Tiles are rectangles with their edges oriented due north and due
east (relative to the coordinate grid); under favorable conditions, tiles can be used to
represent sections in the US Public Land Survey System.  Text labels are text at a given
point. such as the nalne of a school.  RasterGrids consist of a value at each point on a
regular grid, used for things such as elevation.  They tend to be huge and unwieldy and
their use is discouraged unless you have a good reason.

Two other useful concepts before beginning are the DataBounds and the
ViewBounds of a map.  As map themes are created, data is loaded into memory .  The
region occupied by the data is refened to as the DataBounds (the areal extent of the
data).  The region cunently being viewed in the map window is the ViewBounds or view
region.

Clotting Started
h order to begin a session with Wheat E-MAP, you first open a database

containing the geographic infomation.  You do this by starting E-MAP, and selecting
File=>Open_Database... from the menu, then choosing a database that contains the
geographic infomation you wish to display.  Once you have successfully opened a
database, several dinmed menu options become undimmed and you can beSn designing a
map.

Loading Heviously Defined Themes
If there are previously defined themes saved in the database, you can choose

File=>Open_Map_Theme.„ to display a hit of map themes that have been saved.   (These
map themes are defined in a table called zWIITtblThemes, to which you can save theme
definitions from the File=>Save_Theme... menu item or edit by hand once you know how.)
The list on the left is the available themes, the nst on the right is the themes you have so
far chosen to display.  You add a theme to display by selecting it on the list at left, then
double{lic]dng on it or clicking on the > command button.  Double cncking a theme hated
on the left removes it from the fist of themes to dispky, as does clicking on the < button.
(This should be a lot like the font manager in the Windows Control Panel.)  Once the
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themes you want are hated in the hit on the left, cHck OK to accept, or Cane.I to not load
any themes.

Loading a New Theme
BeSn by deciding what kind of theme you wish to display ®oint, line, polygon, or

such) and selecting File=>New_Map_Theme=>Symbels... or
File=> New_Map_Theme=>Polygons... or whatever you want.  You then choose the table or
query containing the infomation you want from a hit of tables and queries available in the
database.  E-MAp checks the field names and, based on settings in your WIHAT.INI ffle,
makes guesses about what fields might be used for what.  Thus, if you're trying to draw a
symbol themes, and have fields by the names of X_Lambert, Y_Irambert, Symbolcode,
Fontcode, AppropriationName, WellTotalDepth and AppropriationNumber. E-MAP will
add X_Lanbert to the list of potential fields for X, Y_hambert to the list of potential
fields for Y, Symbolcode and Fontcode to the list of fields for Symbolcode and
Fontcode, and AppropriationName will be its guess for a field for unique name.  You can
enter constants in any of the fields provided except X and Y, or you can choose a field
nane.

If the color you want is not hated in the dropdown box, cnck on the label Color,
and a dialogue box will appear from which you can select a color.  This is the same color
dialogue as most other Windows appficatious use.  For symbol codes, crick on the label
Symbol, and a dialogue box that displays symbol codes and symbols will appear.  The up
and down arrows can be used to browse symbols in the cunently selected font.  Choose
OK and that symbol code (the ascfi character number of the symbol) will be added to the
fist of symbol codes as the cunently selected symbol.

Note that WellTotalDepth was not added to any of the fists in the previous
example except the list of all plottable fields.  If you want to add a field to a hit or use it
for a criteria, select the field in the list of fields.  You can then copy it to desired location
using standard Windows keyboard cut-and-paste commands, or you can click on the
button labeled Drag Field Nalne, move the icon that appears using the mouse, and cnck
the left mouse button to add the field name to the whatever list you drop it on.  (This is
actually easier done than said.)  If you drop the icon on the label next to a text box, it will
overwrite that whole text box.  If you drop it on the text box itself. it will paste the field
name at the current inserdon point.  (Ibis is mainly useful in setting criteria.)

Once you have chosen how the theme should be plotted, select OK and E-MAP
will run a query based on your choices. load the data into memory and draw it.  If you
choose Cancel, it will not load the data.  Unless you do something about it, E-MAP
displays the themes in the order you added them in, so it's usually best to start with
polygons and tiles, then add lines, points, and labels.  You can crick on Stop F]edrawing to
halt the current Screen redrawing, or you can force a new redrawing by clicking on
Ft®fr®sh Map.

Sometimes, your choices lead to a query containing no records.  (h the school
example, you might have had a criteria with the PrincipalNIme±"REWPOUFDS :LK", in
which case you would get back an empty query).  When this happens, E-MAP usually does
not do anything other than display an error message.  Sometimes, the query defines an
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absurd area and the DataBounds and ViewBounds are reset to unreasonable values, in
which case it's easiest to simply start over.

If the data of interest is spread over two or more tables, or needs to be linited
more than can be done with the criteria box on the spatial query foms, use Access or
some other database manager to define the query needed.

Adjusting what is displayed
By checking or unchecking a theme under the window brought up by

Options=>Themes_Visible ..., you can toggle whether the theme will be shown or not.  This
is useful if you have a theme containing lots of data that takes a long time to draw, and
you just need to navigate.  Ouvers, roads, and soft polygons cause this problem a lot.)  By
clicking on the scron bars, you can adjust the ViewRegion.  Numerous options under the
View menu alow various adjustments of the view region.  h the
View=>Specify_View_Region window, you can enter a view region by hand, either by
defining the bounding rectangle or the center point and the size of the view region.  You
need to hit the ENTER key after entering a number in one of the text boxes for it to take
effect

By clicking Options=>Themes_Order„,, you bring up a window sinilar to the Load
Themes  and Save Themes windows, except that this win control plot order instead of
what themes have been loaded or saved.

When E-MAP starts, it will automatically expand the DataRegion to include every
theme that has been added.  If you're looking at a county and have a statewide road
dataset, this would be annoying.  The solution is to load themes to define your area of
interest then make sure that Options=>Expand_Map_Arcs_to_lnelude_All_Data is
unchecked.  This only affects themes as they are loaded, so tuning it back on later win
allow each theme to expand the DataRegion as appropriate.

If re-display of the map is taking too long and you wish to adjust the view region
by scrolling the scroll bars or by choosing View=>ShifLF]ight and View=>Zcom_ln and such,
unchecking Options=>F]edraw_Map_Whenever_View_Shifts will cause E-MAP to not re-
draw until you tell it to.  If you will be looking at one area for a long time and moving
back and forth between applications, you probably want to check
Options=>Keep_Copy_oLMap_in_Memory to prevent long screen redraws.

If other applications are giving Out of Memory EITors, make sure
Opt.IonsE>Unlcad_foms_After_Use_to_Free_Memory is checked.  This keeps E-Map from
using as much memory, but it does not keep track of your last choices for a theme
definition so you can load a snghtly modified theme definitiorL

Saving, Loading, Printing
Cince you have designed a map theme you like, you can save its definition using

menu Plle=>SaIve_Map_Theme ....  You can load a previously saved theme selecting
File>Open_Map_Theme ....  You can print to the default Windows printer by selecting
File>Print ....  This brings up a dialogue window with blue rectantle indicating the area
that will be cecupied by the map; it can be changed by dragSng and dropping the sizing
handles.  The map title can be set by typing in the text box at the top of the form.  Once
you have entered the title, double-click on the text box, then drag-andrdrop the title onto
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the page-layout box. Choosing Printer S®tup... allows you to change the default printer
and its orientation.  Choose OK or Cancel to print or not print.

Spatial Querying with WlmAT E-MAp
Once you have displayed a theme with E-MAP, you may want to perform spatial

queries, such as finding the river closest to a given point, or assemble a list of all points
within a five-mile radius.  With Wheat E-MAp, you do this by running a spatial query.  To
seleet the theme and type of spatial query, choose menu Options>Spatial_Query ....  When
the dialog box is displayed, select the theme containing the data you wish to search, the
I)pe of spatial query, and click on OK.  To turn off spatial querying, select None for the
spatial query type and click on 01(.  When the map has redrawn. you can perform a spatial
query by double<ncking on the map with the mouse.  For more precision, you can enter
the coordinates in the text box at the upper right, and cnck on run spatial query.  Either
way, E-MAp highlights the point the spatial query will be run with, and loads the data into
the datagrid at the lower right comer.  h addition, each time you run a spatial query, a
new row (or several) are added to the datagrid in the Spatial Query Results window.  You
can copy these results to other Windows appncations using the clipboard and standard
Windows commands, or save the results to a table or a file by choosing menu options.

If you have many points on which you wish to perfom spatial queries, you can
store them in a table, load a theme to display them, load the other theme you want to run
the spatial query with, then choose File=>Spatial_Analysis ....  This will bring up a screen
which will allow you to use the points from one spatial query to nm a series of spatial
queries on another theme.  For instance, you could find the nearest river to each weu by 1)
loading the weus, 2) loading the rivers, choosing Plle=>Spatial_Analysis ..., then specifying
that you want to find the closest line in Lines: Rivers to each point in Symbols: Weus.
The result is a new table containing the name of the point, the name of the other feature,
of the original layers, a distance (if it makes sense), and a line connecting the two features
(if it makes sense and was feasible).

Working with Other Applications
Cine of the main purposes in developing E-MAp was to allow other applications to

analyze and manipulate data shared with WrRAT.  A copy of the current map can be
copied as a Windows Metaffle to the cupboard for pasting into a graphics application like
CorelDraw or Powerpoint,  To do this, click on the map region once you have it looking
the way you want; choose Edit=>Copy to copy the map to the cnpboard; go into the other
appucation; choose Edit=>Paste; and a copy of the map should appear.  Qf it is invisible or
upside down, try ungrouping it.  It turns out some things are not as standard as they could
be.)  To save the map into a Windows Metafile, choose File=>Export ..., then supply a file
name.

To copy textual data. like the results of a spatial query, to some other application,
like a spreadsheet or word processor, run the spatial query, then choose the data you wish
to copy (typically by clicking on the upper left comer of whatever grid contains the data
you're interested in) then choosing Edit=>Copy or Copy .  Go to the other appncation,
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choose Edit=>Paste, and the data should appear laid out as a table with the columns
labeled.

Adding Spatial Features with WlmAT E-MAP
In addition to displaying and querying preexisting features, E-MAp allows you to

add new features with the mouse.  You do this by selecting Edit=>Add=>Lines or =>Points
or >Polygons.  Then click the mouse on the desired location(s) to add (a) feature(s).  If
you are adding lines or polygons, using the space bar will end the current feature, and
allow you to start a new one. To stop adding features, seleet Edit=>Add=>Stop.  Remember
to save your results to a file or table or copy them to some other application before
quitting E-MAP.  Lines and polygons, which are stored in AScn format for readabifty,
need to be converted to XYBLOBs before dispkying in FMAp using the included
BLOBREM0 utility program, which allows conversion either way.

Keyboard Shortcuts While Vlewing a Map
While the map window in E-Map has the focus, (if you don't know what that

means, see the Windows manual or ask an experienced Windows user what that means
and how to set the focus.) a number of keyboard shortcuts are avalable.  The arrow keys
can be used to move the cursor location. with plain arrow keys moving it one pixel,
CoNIROLled allow keys moving it 5 pixels. and AIJTed arrows moving it 20 pixels.  Hitting
the ESCAPE key while the map has the fceus will halt a screen redraw, as will GIRL-BREAK.
Hitting X will cause the current cursor location to be copied to the cupboard (as in "X"
marks the spot).Flitting H will highlight the current point.  As mentioned earlier, if you are
adding lines or polygons using the mouse, using the space bar will end the current feature,
and allow you to start a new one.
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How to Design and Build a WlmAT Database
This document explains how to design a database for use with the Windows-based
Hydrogeologic Exploration and Analysis Tool]dt (WmAT) and how to use the inport-
export tools included in WrnIAT.  It is intended as a planning reference in designing a
database for use with WREAT, and particularly for use with the electronic mapping
appncation E-MAp.
This document assumes you are fanhiar with the use of E-MAP, the particular problems
you or your client will be using WREAT to solve, and somewhat finiliar with the design of
hdicrosoft Access relational databases.  If you are unfamiliar with E-MAP, stop now and
use E-MAP with the sample database;  once you understand E-MAP from a user's
perspective, come back here.  If you are not familiar with the problems your client wishes
to solve. sit down and talk.  If you are totally unfamiliar with relational database design,
buy a copy of Microsoft Access. and at least read the Geffl.ng Slzzrfcd manual before
proceeding.  It is much easier to use Wheat if a commereial qualty database management
package, specifically Access, is used.

Greg Pouch
Kansas Geological Survey

Tuesday, December 06, 1994
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How WHEAT stores data
WEHAT uses data stored in a Microsoft Access fonnat relational database for both

the attributes and coordinates of various geographic features.  The hdicrosoft Access
database format is also the native database fomat for Visual Basic 3.0.

A relational database stores all infomation on a topic, such as water users or
schools, in tables.  Tables are organized sets of infomation containing records, one for
each individual thing in the database.  A record is composed of fields, which describe the
thing.  Thus, a table concerning schools might have records for each school in a county,
and the records might include the name (as text), date founded (as date). operating budget
(as a floating point number), date closed (as date), number of buses owned (as integer
number), principal's name (as text), and number of pupiis (as integer number).  Notice that
some of the fields listed, such as date closed and number of buses, will not cecur for each
individual school.  h these cases, a relational database stores a null, indicating that no
infomation is available.

While a relational database sfores infomation in tables, it can rcfrz'cvc infomation
as virtual tables called queries.  A query is the answer to a question asked about the
datatable, such as:  "show all schools with an operating budget above $5cO,OcO".  A query
can return data from several related tables by joining them.  For example, suppose we had
another table containing infomation about students.  It might contain student's name, age,
address, and name of school attended.  We could then find out who a student's principal is
by designing a query which relates the school name field in the student table to the name
field in the school table.  Queries are generally used for combining infomation from
several tables. selecting subsets of records, or selecting subsets of fields.  By allowing data
to be stored in a single lceation (such as the principal's name in the school field) and
related at a later time, relational databases can reduce storage requirements, and allow the
updating of data to be considerably easier than if each record contained al data that might
ever be needed.

E-MAP uses a relational database to store infomation about geographic features,
both their descriptive (or tabular) atributes and their locational athibutes.  The lceation(s)
of feature are described as X (east-west) and Y (north-south).  WREAT does not use any
particular coordinate system. except that X and Y will be plotted as equal distances on the
screen and on prindng, and X increases to the right and Y increases to the top.

For points (for plotting symbols or text), WIIEAI stores the X and Y lacatious in
separate numerical fields in the table.  These might be named something like Northing and
Basting or X and Y, although, since the fields containing coordinates are chosen by the
user while running E-MAp, they can be named anything.  For features with multiple
lacatious, like the set of line segments defining a river or the boundaries of a county,
WEmT Stores the data in a special type of field called a Binary I:urge Object GLOB or
XYBLOB).  This is sinply a binary representation of a set of X and Y lceations, stored as
a chain of points.

The atributes and lcoational infomation can all be stored in one table for each set
of items, or they can be Stored in separate tables and related in a query.  Additionally,
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plotting instructions (like color, line width, and symbol) can be stored in a table or defined
as constants.

Getting Data into a WlmAT Database
There are two main classes of geometric features handled by Wheat:  1) Points;

and 2) Lines and Polygons.  The fomer are geometically described by a single coordinate
pair, the latter by an ordered chain of coordinates.  For points, the X and Y coordinates
are stored as separate fields.  For lines and polygons, the points on the line or boundary
are all stored in a Binary Large Object field (refened to as an OLE field in the Access
documentation and LargeBinary field in the Visual Basic dceumentation).

Other Windows Applications
If the data is coming from some other Windows or other PC-based application, the

easiest approach is to export it as a comma-separated, quote-delimited ascii text file, and
use the FfleTmport_Delinited option in Access to import it.  There is no equivalent
technique in WHEAT.  For point data, simply include the coordinates as fields in the data
ffle.  A typical file might look like the following

Wet D','ne',.approprialion',LLse code 1 ',hare Cod 2`,tycar','srate','intrs','inrs',ho','approp2'.Basting UIM 14' ,Nofthing UTM 14'
'SF_o33520',iooo,24o,3..'G','A79',o.57,I,o,I.24o,520569.3,4.23448icro6

SF_o33447.33524,'5','G`,'A79',o.57,1,I,124,537534.3.4.23452icro6
'SF_039054',12cO,195,3',G'.'A88',O.57,1.0,1,195,513611.8,4.234248e+06
'SF_o27o75'.715,i3i,'3.,G'.'A76',o.57,I,o,1,i3i.52oi2i.3.4.234234cro6
'SF_026135',1000,183,3','G','A76',0.57,1.0,1,183j08122.3,4.234142e+06
`SF_026134`,810,183,'3'.'G',`A76',0.57,1,0,I,183,508891.3.4.234143e+06

SF_037847',1200,110,3','G',`A85'.0.57,1.0,1,Ilo,511288.9,4.234149eco6
sF_039068',i2OO,85,3',G`,'A88',0.57,1.0,I,85.5ii288.9,4.234i49cro6
`sF_02728i',goo,228,3',¢','A76',0.57,I,O,iz8,5i2907,4.234i52cro6

For line/polygon data, the coordinates should also be included as one field in the
data ffle, but with some complications.  The XY-chains need to be stored in a field with
the coordinates in XiYi X2Y2 ... XNYN order, with separators between the X and Y
coordinates, and AFTER EACH XY PAR, including the last one.  The separators must
be something other than commas, quotes and spaces.  A good choice for XY separators
would be a carat (^) , and a semi-colon (;) after each XY pair.  This win be imported into
a memo or text field in the datatable, and you will then convert it to an XY blob using
BLOBMEMO.ERE (described below).  An tyT]ical file might look like the following
"CintyNane","CNTYABBR".ThstiDg UIM 14".-Ncuthing UTM 14" ,T[YCondimtes"
"BARTON-."BT.521460.8,4.258134e+06..497180.34282925i497181.64282849i497184.14282415:497161.44282109;497166.

4428i445;497167.8ap28i266:497172.8M280577;497i77.9M2799i3;497179.i«279657;497158.94279Oi9:497162,8M27845
9i497166.6ng278o49i497i7o.4Mz775i4i497i74.24276952i497i5i.44276569i497i52.8427644oi497i55.3i276o83i49716o.
4427547o:497164.ing27496i:4987885ng2829i3i497i8o.3qu282925;"

•RICE","RC.568892.I,4.244567ero6,"545538.i4234684gr57i74234685$46i25.6^4234662giv6201.8V2346635462o5.3423
4280:j46209.6^4233745#6211.14233489946249.44224887#6249.44224887#6428.4M224913#7679.34224948;547
7sO.9^42Z4948.j48852.8V224956#9414.1V224962j50945.74224998551023,2M224999552605.9^4224985552682.1V22
4985.j53907.4M225046.j455i4.742379Oigr5526AM236293giv5538.iv234684;"

This ffle has commas separating fields, semi<olous separating XY pairs, and carats
separating X and Y.  The Basting UTM14 and Northing UTM14 fields contain points in
the middle of the county, which is useful for labeling them.
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Once this file is imported into Access as a delimited text fiife, you would then use
BLOBREM0 to produce an XYBL0B field that WIRAT can use for plotting a
hue/polygon.

Using BLOBMEMO
BLOBREMO.EXE is a utility included in Wheat to anow the conversion of XY-

chains representing lines or polygons from binary GLOB) to ascii (REMO) fomats, and
from ascfi to binary.  E-MAp uses only the binary format.  Continuing the example above,
suppose you have imported the county outlines into a table called A_Q1_EXP.  You
would start BLOBMEMO, open the database containing the data using FILE=>OPEN ...,
then choose the table or query containing the ascii XY{hains.  Then you would make sure
the desired MEMO field was selected in the hit on the right, accept the default name
provided or enter your choice of names in the list on the left, select the correct delimiter
characters (in this case, a carat and a semi-colon), then click the M®mo_to_BLOB and the

To convert a binary XY-chain (an XYBLOB) to an ascfi XY-chain, you would
select the database and ffle as above, select the fields or choose a new mane for the output
field as above, and choose the separators from the hits, then click the BLOB_to_M®mo
button. and the program converts the XYBLOB field on the left and stores the ascii
output in the XYMemo field on the right.

ARCINFO
For point data coming from ARCDTFO, just ADDXY to the PAT and UNLOAD it

within TABLES or INFO.  Then import it into Access using the delimited option, making
sure to indicate that ` is used as the text deliniter.  For line and polygon data coming from
ARC/INFO, make sure the COVERAGENAMFD is unique, UNGENEPIATE the
coverage using the line or poly option and export the AAT and/or PAT delimited files
with the UNLOAD command, then move everything to the PC.  Once there, import the
PAT/AAT using the sane method described above.  (You will probably have to edit field
names to eliminate # , . , and - characters.)  Then use the WIEN' application ARCS_IN2
to import the generate fomat ffles containing the arcs (and optional label points) into the
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database.  This will create a table with fields containing the XYBLOB and LineDNumber.
The LinelDNumber is COVERAGENARE-ID item from the AATfl?AT.  To link the
AATffAT to the geometry, create a query joining the two tables with a joining
COVERAGENARE-ID to LineDNumber.  You can leave this query in place and
produce maps based on the query, or you can make this a make-table query and store the
results;  the latter method is preferable.

ARCS_IN2 is used to inport arcs from an ARC/INFO generate format ffie into a
WmAT format table in a database.  This is done by starting ARCS_IN2, opening the
database, opening the file containing the arcs, and choosing the Plle=>lmport_Now menu
item.  If you have many generate files in the same directory, you can import them all at
once using File=>lmport_All_Files_In_Directory.., then choosing a wildcard sting and the
directory to search.

Fixed Width Files
Many mainframe and PC programs produce data ffles where the fields are not

delinited by spacing or with other characters, but by position within a record.  Most
USGS databases produce output in this fomat. such as the fliife below.  You can either use
the Access File=>Import...Fixed Width menu option and type in the definition or use the
VVIieat program FrowDTH1.EXE to inport such ffles.
Ekamp]e Fixed Width Data File
400000102000000125SC00104804AAC            SWNENES04TOOI SF]048W§    4220.00Wl               215
380835102000400011 SC02204813BAA            NENENWS13T022SF`048WS    3795.cows              17.a
eel 31 gio2ooi 4oooi isco2io48i 3cAA           NENEswsi3To2i sF]o48ws    3842.oowi            46.a
eei2o31 o2oo3ooooi 1 sco2i o48258882           NWNWNWs25To2i sF]o48WS    3842.oowl             44.o
381203102003001011SC02104825BBEP
380742i 020032Oooi 1 sco2204824BBB            NWNWNws24T022sF]048ws    37ee.OO u             12.O

Such programs almost always generate a description file such as the one below, which
FXDWDTEIl takes advantage of.  Sinply edit the description ffle to look like the one
below.  Blank lines and anything after a ` are treated as comments.  Field names and table
names cannot contain blanks.  The first active line contains the keyword TableName
followed by the desired table name, the next active line contains the keyword Style
fouowed by the layout keyword NamestartwidthType.  All subsequent lines contain a field
name, the starting column, the number of columns the data cecupies, the type of data
(integer, long, single, double, text. memo, date, or FORTRAN datatype names), and for
text fields. the maxinum length of text.  See the on-line help for more details
hacri tion File Exan
rThls ls on example of a d®scrlpton file  for F)odwdth.  Even those llroo, b®causo they
'9tart `^th single quoee.  ITils ls .xampl. was a.n.rated try the USGS's GWSI databes..

'Th. above llib was lntontlonelly left block.
tablenam. Wu5teD.ecdp6oncolorado
styl. NAMEST^R"l DTHTYPE

ShelD_StathNumber 1    1S    toxtl6'Thl®orlSnallyhad
per.nthee®., `whlch call.od Fwh^/dth tD c*coh.  Note use

ol shg. quote tD 9brt a comment.
Counfycto
LocowdiNumber
LndN.qiacafroA~urfac®

scorsitD

16   3   lntry
ig   24    tord24

43  23   un23
ee   e   ,giv4
74    1    chaeeterl
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Choosing Field Names
Any Access-allowed field name can be used by WREAT, except that field names

should not begin with ZQ.  To preserve portability in case you should decide to move to
another database management system, it is best to linit field names to letters and numbers
and use no punctuation other than underscores (..  In particular, avoid commas, periods,
parentheses, brackets, and anything that might look like a mathematical function or
operator.  The word "date" is reserved as an Access keyword, but "date_" works fine.
Avoiding spaces in field names, and using capitalizalon to indicate word breaks is useful
as well, as in naming a field AppropriationDate rather than Appropriation Date.  It is
safest if the lengths of field names are kept below 16 characters

When the user designs a theme, he/she is actually designing a Structured Query
I-anguage (SQL) query telling E-MAP which fields or constants to use for feature
attributes like X and Y coordinates, symbol sire, symbol code, and color.  (SQL is a
computer language used to handle databases.  See the Access manual or any of many
widely available books that discuss databases and SQL for more infomation.)  These
query statements are in text boxes on the right side of the fom, and can be modified by a
user interested in doing so.  Qf you want to use a calculated field, enclose the whole
calculation in parentheses, and field names should be in square brackets.)  A typical theme
definition might look like
SELECT DISTINCTPIOW [County line] AS zqpolygonoutline, [Plotcotor] AS zqFillcotor, 0 AS
zqFillstyle, 0 AS zqoutlinecolor, 2 AS zqoutlinewidth, format([CountyName]) AS
zqFcatureName  FF]OM [Counties]  ORDEF] BY [Pfotcotor] , 0 , 0 , 2 ;
The SEIECT clause indicates series of field names and constants aliased to fields starting
with ZQ.  If you nane a field zqFillcolor and choose it as the fill color, it win result in
circular definition problems.  The FROM clause specifies that the data come from a table
called Counties.  The ORDER BY clause is used to speed redraws and minimize the size
of graphics files- you should ignore it.

When using E-MAp, the program guesses at what fields might contain coordinates
or plotting instructions based on the field name and the search strings contained in the
DefaultFields] section of the WIHAT.INI file.  By carefully choosing field names, E-
MAp can be very intuitive for the user.

Each of the keywords in the DefaultFields section ends with LookFor or
ShowAlways.  Not surprisingly, the I+ockFor lines contain sulngs that will be searched for
in the list of fields and ShowAlways lines contain constants that will be included below the
fields in the list.  The constants and strings are separated by spaces, and each line should
have one space after the last word.  h the example below, any field containing the string
FONT will be added to the symbol size nst in the text labels and symbols dialogue
windows, and the constants 10, 12, 18, 24, and 36 will always be shown.
qraultEdds]
sizeLco]ftrfoNTsrzE IHGm WID'nl sE roNT
SizeshomrAlwrys =10 12 18 24 36

LOR COLOUR TINT IIUE
Cctarsho"AI"ysac>Black 255<oBrignRed 65280caBriptcheeD 16711680¢>BfightB lu. 8421504e>Gray

16777215<±White 65535<>Y®»ow 33023¢ochng®
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S)mbolcodcLockFof=esYMBOLcODE
S]mbolcodesl)owAlways=45 51 33
xLOokFdrx_EASTWESTLONG
VLcokFa=Y_ NORnl SOUTII IAT
FtateNlmeLcokFor=esERIALNAhGID#NutoER
x¥IndFcl=E[TBLOBcllAINLINEpoLTBORDERBoUNDART
FontcodeLoolcFor=FDNlcoDE FONT TYPE
FbDreodeshowAlways=O 1 2 3
Fe.aDeToxtl+oolEFot=1Hr IABEL NAME
fe.nkeTextshowAlwnysrm_You_Meesagc_Hcte~Ip_halblcQuctes
LinewidthLookFor=IJREWID" ivID" LINE ivIDE
LinewidthshowAlways=1 2 3 4 5 6
LiBestyldndFor±nlESTYIE STYIE LINE TYPE
hinestyleshowAlwayscoc>Solid I ¢>Dach 2<>Dot 3<=Dach-Dot 4©D.drDot-Dot 5ceTranaparent 6c>ln!ide_Solid
Finistyleho]tFbt=inlsTyu3FnLsTvll3INIERIORINslDE
FuiHIstylcshovAlw&yF0cesolid1ceTranapa[eDt2®Iforizomal3®Verical4ceupward_Diagonal5esDounwh_"agoml

6coHVGes=(+) 7<oDiagonalGos3(I)
Alignll]enfrockFo[=ALIGN ORIENT
AlignnentshowAlwaLy±LeftLTap 2<>RIghLTap 6e>CeDter_Tap 8ceLed_Botlon loesRighLBcttom

14coGener_Bonom 24caLeft_Baseline 26c>RIghLBaselitie 30cecentcLB aselino

By having X_ as the first entry on the XI+ookFor line and naming all fields
containing X coordinates X_Center or X_Weu or even just X. the program win correctly
choose those fields as the default X coordinate where an X coordinate is caued for.  If  the
field name does not appear in the proper Hsts, the user can still drag the field name to the
risL

Spatial Querying with WHEAT E-MAP
Once you have displayed a theme with E-MAp, you may want to perfom spatial

queries, such as finding the river closest to a given point, or assemble a nst of all points
within a five-mile radius.  With Wheat E-MAp, you do this by running a spatial query.  To
select the theme and type of spatial query, choose menu Opt.rons=>Spatial_Query ....  When
the dialogue box is displayed, select the theme containing the data you wish to search, the
type of spatial query, and click on oK.

Unique Names Needed for Spatial Querying
When E-MAP loads data on a feature into a theme, it stores a feature name.  When

E-MAP perfoms a spatial query, it gets the feature name from the theme, then nms a
query looking for all data in records where that feature name cocurs and displays the
results in the datagrid and spatial query results window.  Because of this, it is inportant
that tables contain a column of data suitable for performing this link  This should be one
column with unique values, such as a serial number.  Tim FEATURE NAME SHOULD
BE UNIQUE or you will end up returning incorrect results.  A one-field primary key
would be best.

One-To-Many Spatial Queries
When the user saves a theme definition, E-Map writes the SQL statement that

defines the graphical data and the SQL statement that defines the tabular data to be
retrieved by a spatial query in fields Mapsource and DBSource in table
zWIHATtblThemes.  You can modify these definitions to suit your needs.  For instance,
if we had county outlines that we wished to display from a table called Counties, but
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census data in a table called Countiescensus which contains census data for each decade
for each county (a one-to-many relate between counties and census data), and we want to
be able to select a county and rerieve census data, we could add a new record to the
zWIHATtblThemes table, set the Mapsource field to
SEucT DIsllNCITF]OW (Cfroty liro] AS zqpolygonoutlin., [Ptotcolor| AS zqFillcotor, a AS zqFillsty®, 0 AS

zqoutlin®Coler, 2 AS zqoutlln®Width, Iomat([CountyNam®]) AS zqFeedr.Name  FF`OM [Cound®s]  ORDEF` BY
(Plctcfty] , a , a , 2 :

and set the DBSouree field to
SELECT DISTINCTROW .. formatt[CountyNain®]) AS zqFcatw®Nam® FF]OM (Count]®sconsus]  ORDER BY [C®nsusYoar);

and the ThemeName field to "Counties with Census Data", then loading that theme will
allow us to perform the desired one-to-many spatial query.  This technique is useful
whenever many observations might be assceiated with a single geographic feature, such as
water levels with a weu or soil layers with a soil series polygon.

Adding Spatial Features with WlmAT E-MAp

In addition to displaying and querying preexisting fcatures, E-MAP allows you to
end new features with the mouse.  You do this by selecting Edit=>Add=>Lines or =>Points
or >Polygons.  Then cnck the mouse on the desired location(s) to add (a) feature(s).  If
you are adding lines or polygons, using the space bar will end the current feature, and
allow you to start a new o`ne. To Stop adding features, select Edit>Add=>Stop.  Remember
to save your results to a file or table or copy them to some other application before
quitting E-MAP.  hines and polygons, which are stored in AScn fomat for readabhity,
need to be converted to XYBLOBs before displaying in E-MAp using the included
BLOBREMO utility program, which avows conversion either way.
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How to Contour in WREAT
This document explains the use of the contouring tool (contourl.exe) included in the
Windows-based Hydrogeologic Exploration and Analysis Toolkit (WmAT).  The
contouring tool takes scattered measurements with X. Y and Z values from a table or
query, grids them, then contours them.  The gnd is saved as a WREAT rastergrid, and the
contours are saved to a new table whose fields include the contour, its value, and a serial
number.  This paper is intended as a how-to introduction to contouring for geologists and
assumes you already have a database.  If you do not already have a database, read the E-
MAp manual first, then build a database using the guidelines suggested in How fo Desz.gn
and Buiid a Wheat Database.

Greg Pouch
Kansas Geological Survey

Tuesday, December 06, 1994
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Background and Terminology
A contour is a line that passes through a set of lacatious where some variable has a

particular value.  On a topographic map, a line comecting points where the elevation (the
variable or Z-value) is 2100' (the paricular value) is a contour.  The Z-value can be any
quantifiable variable, such as water level, bedrock elevation, temperature, or magnetic
field strength intensity.  By convention, X measures distance in the east-west direction and
Y measures the north-south position, with X increasing to the east and Y increasing to the
north.  Cia topographic maps, the interval between contours is fixed at the contour
interval;  this need not be so and the contour-tool dces not require it.
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Open the database
1)  Open the database containing the data you wish to contour by choosing

File=>Open_Database...

Choose Field to Contour
2)  To contour scattered XYZ data already in the database (the only supported option)

Choose Fi le=> O pen_WheaLData.. => Scattered_XYZ_from_a ueryITab le .... That will bring
up the following dialog box.  Choose the name of the table of query containing the
data you want to contour, the field you want to contour in the dropdown list labeled
Field Containing the Value to be Gridded, and the fields containing X and Y (often
X_Something and Y_Something, or Basting and Northing) in the appropriate lists.
Then click on the 01( button.

If you wish to stipulate additional selection criteria add these to the Criteria box.  For
example, suppose you have already chosen a query containing all water levels, Z, X
and Y, and now wish to linit the contouring to only water levels whose date is
between 1 August 1984 and 5 May 1985.  Then you would add the text

(P)ateMeasurement] between #8/1/1984# and #5/5/ 1985#)

to the criteria box.  alead the Microsoft Access manual or any text on SQL for details
of setthg criteria.)
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Choose Gridding Method

3)  That will bring up the following dialog box, which asks how you want to grid the data.
First choose a convenienL descriptive name for the rastergrid you will be generating.
h the example below, the gridded net quantities will be stored in a rastergnd called
"1970 NctQuantify' and the contours will go into a table called "Contours from 1970

NetQuantity".  NexL choose which points to include in interpolating and how to
intapolate.  For noisy data, I use Quadrant search for closest 2 points and VR2
interpolation; with less noise, Quadrant search for closest 1 points and VR2 .  In both
the X and Y direetious, you can choose either how many grid cells to have, or how far
apart their centers are, to control the speed of execution (few ceus) or the smoothness
of the lines (more ceus, spaced closely).  To set the X cell spacing to loon, type
lug in the textbox labeled X Cell Size, then hit return.  The Number of X Cells
textbox is updated to reflect this change.  If you enter the Number of X Cens, then hit
return, the X Cell Size is updated.  When you are done ma]ring selections, cnck on OK
to accept or Cancel to abandon contouring.

The program then grids your data.  This often takes a long time, so this is a good
tine to get some coffee.
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Choose contours
4)  After gridding you data, the program asks for the contour levels.  You can change the

number of contour levels and the linits.  Usually, twenty linearly-spaced contours
from the minimum to the maxinum values is a gcod idea.

You can choose to bound your contour range with the mininum and maximum Z-values,
or the mean +/- some number of standard deviations, or manually override the
mininum and maxinun.

You can change the number of contours:  if the Automatically reset... checkbox is checked,
the number of contours will be decreased to get even contour ranges.

You can also choose linear or logarithmic spacing of contours (I+ogarithmic contours
would be most useful for chemical concentrations or other variables that have a very
large range).

You can also manuany add contour levels by cHcking Add Contour, highlighting the
newly-generated, blank contour level, entering the desired level in the textbox, and
hitting return.  You can remove a contour level by selecting the contour level, then
cHcking D®I®to Contour.

Enally cHck 01( or Cancel and the program will produce contours and store them in a
table which can later be viewed in E-MAp.

At this point, you are done contouring.
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